| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| hydrogen | ≥ 0.10.0, < 0.19.0 | 0.19.0 |
| @shopify/hydrogen | ≥ 0.10.0, < 0.19.0 | 0.19.0 |
There is a potential Cross-Site Scripting (XSS) vulnerability where an arbitrary user is able to execute scripts on pages that are built with Hydrogen. This affects all versions of Hydrogen starting from version 0.10.0 to 0.18.0. This vulnerability is exploitable in applications whose hydrating data is user controlled.
All Hydrogen users should upgrade their project to v0.19.0.
There is no current workaround, and users should update as soon as possible.
Additionally, the Content Security Policy is not an effective mitigation for this vulnerability.
GitHub: Hydrogen v0.19.0 Fix PR: https://github.com/Shopify/hydrogen/pull/1272
If you have any questions or comments about this advisory:
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン