要点
- CVE-2022-41957 は muhammara (muhammara project), hummus, muhammara に影響する深刻度「高」 (CVSS 7.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.1%(全脆弱性の 67.1% より高い)。
- 対処:3.3.0, 2.6.2, 3.4.0 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| muhammara | ≥ 3.0.0, < 3.3.0< 2.6.2
| 3.3.02.6.2
|
| hummus npm | 全バージョン
| 修正版なし |
| muhammara npm | ≥ 3.0.0, < 3.4.0< 2.6.2
| 3.4.02.6.2
|
概要
Impact
The package muhammara before 2.6.2, from 3.0.0 and before 3.3.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.
Patches
It has been patched in 3.4.0 and has been backported to 2.6.2
There is no patch for hummus, currently
Workarounds
Do not process files from untrusted sources or update.
Replace hummus with muhammara
References
https://github.com/julianhille/MuhammaraJS/pull/235
https://github.com/julianhille/MuhammaraJS/pull/238
NVD の説明
Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン