| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| nextcloud server | ≥ 18.0.0, < 20.0.14.12≥ 21.0.0, < 21.0.9.10≥ 22.0.0, < 22.2.10.10≥ 23.0.0, < 23.0.12.5≥ 24.0.0, < 24.0.10≥ 25.0.0, < 25.0.4 | 20.0.14.1221.0.9.1022.2.10.1023.0.12.524.0.1025.0.4 |
Nextcloud server is an open source home cloud implementation. In affected versions a missing scope validation allowed users to create workflows which are designed to be only available for administrators. Some workflows are designed to be RCE by invoking defined scripts, in order to generate PDFs, invoking webhooks or running scripts on the server. Due to this combination depending on the available apps the issue can result in a RCE at the end. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. Users unable to upgrade should disable app `workflow_scripts` and `workflow_pdf_converter` as a mitigation.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン