要点
- CVE-2023-28447 は smarty/smarty, smarty (smarty) に影響する深刻度「中」 (CVSS 6.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.0%(全脆弱性の 63.3% より高い)。
- 対処:4.3.1, 3.1.48 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.3.1< 3.1.48
| 4.3.13.1.48
|
| smarty | ≥ 4.0.0, < 4.3.1< 3.1.48
| 4.3.13.1.48
|
概要
Impact
An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user.
Patches
Please upgrade to the most recent version of Smarty v3 or v4.
For more information
If you have any questions or comments about this advisory please open an issue in the Smarty repo
NVD の説明
Smarty is a template engine for PHP. In affected versions smarty did not properly escape javascript code. An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Users are advised to upgrade to either version 3.1.48 or to 4.3.1 to resolve this issue. There are no known workarounds for this vulnerability.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン