| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.xwiki.platform:xwiki-platform-oldcore | ≥ 14.4.1, < 14.4.7≥ 14.5, < 14.10 | 14.4.714.10 |
| xwiki | = 14.10≥ 14.4.1, < 14.4.7 | 14.4.7 |
The Document script API returns directly a DocumentAuthors allowing to set any authors to the document, which in consequence can allow subsequent executions of scripts since this author is used for checking rights. Example of such attack:
{{velocity}}
$doc.setContent('{{velocity}}$xcontext.context.authorReference{{/velocity}}')
$doc.authors.setContentAuthor('xwiki:XWiki.superadmin')
$doc.getRenderedContent()
{{/velocity}}
The problem has been patched in XWiki 14.10 and 14.4.7 by returning a safe script API.
There no easy workaround apart of upgrading.
If you have any questions or comments about this advisory:
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン