要点
- CVE-2023-39531 は sentry, sentry (sentry) に影響する深刻度「中」 (CVSS 6.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.36%(全脆弱性の 29.3% より高い)。
- 対処:23.7.2 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| sentry PyPI | ≥ 10.0.0, < 23.7.2
| 23.7.2
|
| sentry | ≥ 10.0.0, < 23.7.2
| 23.7.2
|
概要
Impact
An attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account.
Remediation
- Sentry SaaS customers do not need to take any action. Those with the highest risk will be contacted directly by Sentry.
- Self-hosted installations should upgrade to version 23.7.2 or higher.
Workarounds
There are no direct workarounds, but users should review applications authorized on their account (User Settings > Authorized Applications) and remove any that are no longer needed.
NVD の説明
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン