| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| github.com/sagernet/sing | < 0.2.12-0.20230925092853-5b05b5c147d9 | 0.2.12-0.20230925092853-5b05b5c147d9 |
| github.com/sagernet/sing-box | ≥ 1.5.0-beta.1, < 1.5.0-rc.5< 1.4.5 | 1.5.0-rc.51.4.5 |
| sing-box | = 1.5.0< 1.4.5 | 1.4.5 |
This vulnerability allows specially crafted requests to bypass authentication, affecting all SOCKS inbounds with user authentication.
Update to sing-box 1.4.5 or 1.5.0-rc.5 and later versions.
Don't expose the SOCKS5 inbound to insecure environments.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン