| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1, < 10.1.14≥ 11.0.0-M1, < 11.0.0-M12≥ 8.5.0, < 8.5.94≥ 9.0.0-M1, < 9.0.81 | 10.1.1411.0.0-M128.5.949.0.81 |
| org.apache.tomcat:tomcat | ≥ 10.1.0-M1, < 10.1.14≥ 11.0.0-M1, < 11.0.0-M12≥ 8.5.0, < 8.5.94≥ 9.0.0-M1, < 9.0.81 | 10.1.1411.0.0-M128.5.949.0.81 |
| org.apache.tomcat:tomcat-coyote | ≥ 10.1.0-M1, < 10.1.14≥ 11.0.0-M1, < 11.0.0-M12≥ 8.5.0, < 8.5.94≥ 9.0.0-M1, < 9.0.81 | 10.1.1411.0.0-M128.5.949.0.81 |
| tomcat | = 10.1.0= 11.0.0= 9.0.0≥ 10.1.1, < 10.1.14≥ 8.5.0, < 8.5.94≥ 9.0.1, < 9.0.81 | 10.1.148.5.949.0.81 |
Improper Input Validation vulnerability in Apache Tomcat.
Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン