要点
- CVE-2024-24758 は undici (nodejs), undici に影響する深刻度「中」 (CVSS 4.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.77%(全脆弱性の 55.5% より高い)。
- 対処:6.6.1, 5.28.3 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| undici | ≥ 6.0.0, < 6.6.1< 5.28.3
| 6.6.15.28.3
|
| undici npm | ≥ 6.0.0, < 6.6.1< 5.28.3
| 6.6.15.28.3
|
概要
Impact
Undici already cleared Authorization headers on cross-origin redirects, but did not clear Proxy-Authorization headers.
Patches
This is patched in v5.28.3 and v6.6.1
Workarounds
There are no known workarounds.
References
NVD の説明
Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici already cleared Authorization headers on cross-origin redirects, but did not clear `Proxy-Authentication` headers. This issue has been patched in versions 5.28.3 and 6.6.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン