| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| exiv2 | ≥ 0.16.0, < 0.16.1 | 0.16.1 |
| exiv2 | = 0.28.0= 0.28.1 |
A denial-of-service was found in Exiv2 version v0.28.1: an unbounded recursion can cause Exiv2 to crash by exhausting the stack. The vulnerable function, QuickTimeVideo::multipleEntriesDecoder, was new in v0.28.0 (see https://github.com/Exiv2/exiv2/pull/2337), so Exiv2 versions before v0.28 are not affected. Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The denial-of-service is triggered when Exiv2 is used to read the metadata of a crafted video file.
The bug is fixed in version v0.28.2.
Please see our security policy for information about Exiv2 security.
This bug was found by OSS-Fuzz.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン