| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| sulu/sulu | ≥ 2.2.0, < 2.4.17≥ 2.5.0-alpha1, < 2.5.13 | 2.4.172.5.13 |
| sulu | ≥ 2.2.0, < 2.4.17≥ 2.5.0, < 2.5.13 | 2.4.172.5.13 |
What kind of vulnerability is it? Who is impacted?
Access to pages is granted regardless of role permissions for webspaces which have a security system configured and permission check enabled. Webspaces without do not have this issue.
Has the problem been patched? What versions should users upgrade to?
The problem is patched with Version 2.4.17 and 2.5.13.
Is there a way for users to fix or remediate the vulnerability without upgrading?
Remove following lines from vendor/symfony/security-http/HttpUtils.php:
- // Shortcut if request has already been matched before
- if ($request->attributes->has('_route')) {
- return $path === $request->attributes->get('_route');
- }
Or do not install symfony/security-http versions greater equal than v5.4.30 or v6.3.6.
Are there any links users can visit to find out more?
Currently no references.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン