要点
- CVE-2024-31208 は matrix-synapse, synapse (matrix) に影響する深刻度「中」 (CVSS 6.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.5%(全脆弱性の 73.6% より高い)。
- 対処:1.105.1 以降に更新してください。
概要
Impact
A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in how the auth chain cover index is calculated. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service.
Servers in private federations, or those that do not federate, are not affected.
Patches
Server administrators should upgrade to 1.105.1 or later.
Workarounds
One can:
- ban the malicious users or ACL block servers from the rooms; and/or
- leave the room and purge the room using the admin API
For more information
If you have any questions or comments about this advisory, please email us at security AT element.io.
NVD の説明
Synapse is an open-source Matrix homeserver. A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in the V2 state resolution algorithm. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service. Servers in private federations, or those that do not federate, are not affected. Server administrators should upgrade to 1.105.1 or later. Some workarounds are available. One can ban the malicious users or ACL block servers from the rooms and/or leave the room and purge the room using the admin API.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン