| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.xwiki.commons:xwiki-commons-velocity | ≥ 15.0-rc-1, < 15.5.4≥ 15.6-rc-1, < 15.9-rc-1≥ 3.0.1, < 14.10.19 | 15.5.415.9-rc-114.10.19 |
| xwiki | ≥ 15.0, < 15.5.4≥ 15.6, < 15.9≥ 3.0.1, < 14.10.19 | 15.5.415.914.10.19 |
The HTML escaping of escaping tool that is used in XWiki doesn't escape {, which, when used in certain places, allows XWiki syntax injection and thereby remote code execution.
To reproduce in an XWiki installation, open <xwiki-host>/xwiki/bin/view/Panels/PanelLayoutUpdate?place=%7B%7B%2Fhtml%7D%7D%7B%7Basync%20async%3Dfalse%7D%7D%7B%7Bvelocity%7D%7D%23evaluate(%24request.eval)%7B%7B%2Fvelocity%7D%7D%7B%7B%2Fasync%7D%7D&eval=Hello%20from%20URL%20Parameter!%20I%20got%20programming%3A%20%24services.security.authorization.hasAccess(%27programming%27) where <xwiki-host> is the URL of your XWiki installation. If this displays You are not admin on this place Hello from URL Parameter! I got programming: true, the installation is vulnerable.
The vulnerability has been fixed on XWiki 14.10.19, 15.5.5, and 15.9 RC1.
Apart from upgrading, there is no generic workaround. However, replacing $escapetool.html by $escapetool.xml in XWiki documents fixes the vulnerability. In a standard XWiki installation, we're only aware of the document Panels.PanelLayoutUpdate that exposes this vulnerability, patching this document is thus a workaround. Any extension could expose this vulnerability and might thus require patching, too.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン