| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| apache-superset | ≥ 4.0.0, < 4.0.1< 3.1.3 | 4.0.13.1.3 |
| superset | ≥ 4.0.0, < 4.0.1< 3.1.3 | 4.0.13.1.3 |
Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table. This issue affects Apache Superset before version 3.1.3 and in version 4.0.0.
Users are recommended to upgrade to version 4.0.1 or 3.1.3, both of which fix the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン