要点
- CVE-2024-37893 は grumpydictator/firefly-iii に影響する深刻度「中」 (CVSS 5.9) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.59%(全脆弱性の 48.4% より高い)。
- 対処:6.1.17 以降に更新してください。
概要
Impact
A MFA bypass in the Firefly III OAuth flow may allow malicious users to bypass the MFA-check. This allows malicious users to use password spraying to gain access to your Firefly III data using passwords stolen from other sources. As OAuth applications are easily enumerable using an incrementing id, an attacker could try sign an OAuth application up to a users profile quite easily if they have created one. The attacker would also need to know the victims username and password.
Patches
Problem has been patched in Firefly III v6.1.17 and up.
Workarounds
- Use a unique password for your Firefly III instance,
- Store your password securely, i.e. in a password manager or in your head.
References
NVD の説明
Firefly III is a free and open source personal finance manager. In affected versions an MFA bypass in the Firefly III OAuth flow may allow malicious users to bypass the MFA-check. This allows malicious users to use password spraying to gain access to Firefly III data using passwords stolen from other sources. As OAuth applications are easily enumerable using an incrementing id, an attacker could try sign an OAuth application up to a users profile quite easily if they have created one. The attacker would also need to know the victims username and password. This problem has been patched in Firefly III v6.1.17 and up. Users are advised to upgrade. Users unable to upgrade should Use a unique password for their Firefly III instance and store their password securely, i.e. in a password manager.
grumpydictator/firefly-iii のその他の脆弱性
すべて見る →これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン