| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| llama-index | ≥ 0.9.47, < 0.10.13< 0.10.13 | 0.10.13 |
| llama-index-llms-rungpt | < 0.1.3 | 0.1.3 |
| llamaindex | ≥ 0.9.47, < 0.10.13 | 0.10.13 |
A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン