| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| slim select | < 2.9.2 | 2.9.2 |
| slim-select | ≥ 2.0.0, < 2.9.2 | 2.9.2 |
Slim Select 2.0 versions through 2.9.0 are affected by a potential cross-site scripting vulnerability. In select.ts:createOption(), the text variable from the user-provided Options object is assigned to an innerHTML without sanitation. Software that depends on this library to dynamically generate lists using unsanitized user-provided input may be vulnerable to cross-site scripting, resulting in attacker executed JavaScript. This vulnerability is fixed in 2.9.2.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン