要点
- CVE-2025-24013 は codeigniter4/framework, codeigniter (codeigniter) に影響する深刻度「中」 (CVSS 5.3) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.51%(全脆弱性の 43.4% より高い)。
- 対処:4.5.8 以降に更新してください。
概要
Impact
Lack of proper header validation for its name and value. The potential attacker can construct deliberately malformed headers with Header class. This could disrupt application functionality, potentially causing errors or generating invalid HTTP requests. In some cases, these malformed requests might lead to a DoS scenario if a remote service’s web application firewall interprets them as malicious and blocks further communication with the application.
Patches
Upgrade to v4.5.8 or later.
Workarounds
Validate HTTP header keys and/or values if using user-supplied values before passing them to Header class.
Differences from CVE-2023-29197
-
Affected Software:
- CVE-2023-29197 specifically addresses a vulnerability in the
guzzlehttp/psr7 library.
- The reported issue in this Security Advisory is within the CodeIgniter4 framework and does not depend on or use the
guzzlehttp/psr7 library.
-
Root Cause and Implementation:
- The vulnerability reported arises from an issue in the Header class of CodeIgniter4, which is unrelated to the functionality or implementation of
guzzlehttp/psr7.
-
Scope of Impact:
- The vulnerability described in this Security Advisory affects applications built with the CodeIgniter4 framework, which does not use or rely on the
guzzlehttp/psr7 library.
References
NVD の説明
CodeIgniter is a PHP full-stack web framework. Prior to 4.5.8, CodeIgniter lacked proper header validation for its name and value. The potential attacker can construct deliberately malformed headers with Header class. This could disrupt application functionality, potentially causing errors or generating invalid HTTP requests. In some cases, these malformed requests might lead to a DoS scenario if a remote service’s web application firewall interprets them as malicious and blocks further communication with the application. This vulnerability is fixed in 4.5.8.
codeigniter4/framework のその他の脆弱性
すべて見る →これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン