| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.10, < 10.1.40≥ 11.0.0-M2, < 11.0.6≥ 8.5.0, ≤ 8.5.100≥ 9.0.76, < 9.0.104 | 10.1.4011.0.69.0.104 |
| org.apache.tomcat:tomcat-catalina | ≥ 10.1.10, < 10.1.40≥ 11.0.0-M2, < 11.0.6≥ 8.5.0, ≤ 8.5.100≥ 9.0.76, < 9.0.104 | 10.1.4011.0.69.0.104 |
| tomcat | ≥ 10.1.0, < 10.1.40≥ 11.0.0, < 11.0.6≥ 9.0.0, < 9.0.104 | 10.1.4011.0.69.0.104 |
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. For a subset of unlikely rewrite rule configurations, it was possible for a specially crafted request to bypass some rewrite rules. If those rewrite rules effectively enforced security constraints, those constraints could be bypassed.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.5, from 10.1.0-M1 through 10.1.39, from 9.0.0.M1 through 9.0.102. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected.
Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6, which fix the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン