| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.xwiki.platform:xwiki-platform-security-requiredrights-default | ≥ 15.9-rc-1, < 15.10.8≥ 16.0.0-rc-1, < 16.2.0 | 15.10.816.2.0 |
| xwiki | ≥ 15.9, < 15.10.8≥ 16.0.0, < 16.2.0 | 15.10.816.2.0 |
When editing a page, XWiki warns since version 15.9 when there is content on the page like a script macro that would gain more rights due to the editing. This analysis doesn't consider certain kinds of properties, allowing a user to put malicious scripts in there that will be executed after a user with script, admin, or programming rights edited the page. Such a malicious script could impact the confidentiality, integrity and availability of the whole XWiki installation.
To reproduce, as a user without script right, create a class with a TextArea property, create page with an object of that class and a Velocity macro in its content. Then, as an admin, try editing that page. Normally, there should be a warning but in vulnerable versions of XWiki, there is no warning.
This vulnerability has been patched in XWiki 15.10.8 and 16.2.0.
We're not aware of any workarounds apart from not editing pages that might have been edited by untrusted users as a user with script rights, e.g., by using separate user accounts for admin and non-admin tasks.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン