| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.avro:avro-compiler | ≥ 1.12.0, < 1.12.1< 1.11.5 | 1.12.11.11.5 |
| avro | < 1.11.5 | 1.11.5 |
| avro | = 1.12.0< 1.11.5 | 1.11.5 |
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Avro Java SDK when generating specific records from untrusted Avro schemas.
This issue affects Apache Avro Java SDK: all versions through 1.11.4 and version 1.12.0.
Users are recommended to upgrade to version 1.12.1 or 1.11.5, which fix the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン