| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.cxf:cxf-rt-transports-jms | ≥ 4.0.0, < 4.0.9≥ 4.1.0, < 4.1.3< 3.6.8 | 4.0.94.1.33.6.8 |
| cxf | ≥ 4.0.0, < 4.0.9≥ 4.1.0, < 4.1.3< 3.6.8 | 4.0.94.1.33.6.8 |
If untrusted users are allowed to configure JMS for Apache CXF, previously they could use RMI or LDAP URLs, potentially leading to code execution capabilities. This interface is now restricted to reject those protocols, removing this possibility.
Users are recommended to upgrade to versions 3.6.8, 4.0.9 or 4.1.3, which fix this issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン