| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| commons-lang:commons-lang | ≥ 2.0, ≤ 2.6 | |
| org.apache.commons:commons-lang3 | ≥ 3.0, < 3.18.0 | 3.18.0 |
| commons lang | ≥ 2.0, < 2.6≥ 3.0, < 3.18.0 | 2.63.18.0 |
Uncontrolled Recursion vulnerability in Apache Commons Lang.
This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0.
The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop.
Users are recommended to upgrade to version 3.18.0, which fixes the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン