| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.jackrabbit:jackrabbit-core | ≥ 2.20.0, < 2.20.17≥ 2.22.0, < 2.22.1≥ 2.23.0-beta, < 2.23.2-beta | 2.20.172.22.12.23.2-beta |
| org.apache.jackrabbit:jackrabbit-spi-commons | ≥ 2.20.0, < 2.20.17≥ 2.22.0, < 2.22.1≥ 2.23.0-beta, < 2.23.2-beta | 2.20.172.22.12.23.2-beta |
| jackrabbit | = 2.22.0= 2.23.0= 2.23.1≥ 2.20.0, < 2.20.17 | 2.20.17 |
Blind XXE vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges.
Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン