要点
- CVE-2025-54384 は ckan に影響する深刻度「中」 (CVSS 6.3) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.23%(全脆弱性の 13.3% より高い)。
- 対処:2.11.4, 2.10.9 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| ckan PyPI | ≥ 2.11.0, < 2.11.4< 2.10.9
| 2.11.42.10.9
|
概要
Impact
The helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector.
Patches
This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4
NVD の説明
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.9 and 2.11.4, the helpers.markdown_extract() function did not perform sufficient sanitization of input data before wrapping in an HTML literal element. This helper is used to render user-provided data on dataset, resource, organization or group pages (plus any page provided by an extension that used that helper function), leading to a potential XSS vector. This vulnerability has been fixed in CKAN 2.10.9 and 2.11.4.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン