要点
- CVE-2025-58065 は flask-appbuilder, flask-appbuilder (dpgaspar) に影響する深刻度「中」 (CVSS 6.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.43%(全脆弱性の 37.6% より高い)。
- 対処:4.8.1 以降に更新してください。
概要
Impact
When Flask-AppBuilder is configured to use OAuth, LDAP, or other non-database authentication methods, the password reset endpoint remains registered and accessible, despite not being displayed in the user interface. This allows an enabled user to reset their password and be able to create JWT tokens even after the user is disabled on the authentication provider.
Patches
Upgrade to Flask-AppBuilder version 4.8.1 or later
Workarounds
If immediate upgrade is not possible:
- Manually disable password reset routes in the application configuration
- Implement additional access controls at the web server or proxy level to block access to the reset my password URL.
- Monitor for suspicious password reset attempts from disabled accounts
NVD の説明
Flask-AppBuilder is an application development framework. Prior to version 4.8.1, when Flask-AppBuilder is configured to use OAuth, LDAP, or other non-database authentication methods, the password reset endpoint remains registered and accessible, despite not being displayed in the user interface. This allows an enabled user to reset their password and be able to create JWT tokens even after the user is disabled on the authentication provider. Users should upgrade to Flask-AppBuilder version 4.8.1 or later to receive a fix. If immediate upgrade is not possible, manually disable password reset routes in the application configuration; implement additional access controls at the web server or proxy level to block access to the reset my password URL; and/or monitor for suspicious password reset attempts from disabled accounts.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン