要点
- CVE-2025-59837 は astro (astro), astro に影響する深刻度「高」 (CVSS 7.2) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.35%(全脆弱性の 28.8% より高い)。
- 対処:5.13.10 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| astro | ≥ 5.13.4, < 5.13.10
| 5.13.10
|
| astro npm | ≥ 5.13.4, < 5.13.10
| 5.13.10
|
概要
NVD の説明
Astro is a web framework that includes an image proxy. In versions 5.13.4 and later before 5.13.10, the image proxy domain validation can be bypassed by using backslashes in the href parameter, allowing server-side requests to arbitrary URLs. This can lead to server-side request forgery (SSRF) and potentially cross-site scripting (XSS). This vulnerability exists due to an incomplete fix for CVE-2025-58179. Fixed in 5.13.10.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン