| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| pyfory | ≥ 0.12.0, < 0.12.3 | 0.12.3 |
| pyfury | ≥ 0.1.0, ≤ 0.10.3 | |
| fory | ≥ 0.1.0, ≤ 0.10.3≥ 0.12.0, ≤ 0.12.2 |
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of pickle.loads, which is vulnerable to remote code execution.
Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン