要点
- CVE-2025-64168 は agno に影響する深刻度「高」 (CVSS 7.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.16%(全脆弱性の 5.3% より高い)。
- 対処:2.2.2 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| agno PyPI | ≥ 2.0.0, < 2.2.2
| 2.2.2
|
概要
Impact
Under certain conditions (under high concurrency), when session_state is passed to an Agent or Team during run or arun calls, a race condition can occur, causing a session_state to be assigned and persisted to the incorrect session. This may result in user data from one session being exposed to another user.
Patches
This has been patched in version 2.2.2. Upgrade with pip install -U agno.
NVD の説明
Agno is a multi-agent framework, runtime and control plane. From 2.0.0 to before 2.2.2, under high concurrency, when session_state is passed to Agent or Team during run or arun calls, a race condition can occur, causing a session_state to be assigned and persisted to the incorrect session. This may result in user data from one session being exposed to another user. This has been patched in version 2.2.2.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン