| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.causeway.commons:causeway-commons | < 3.5.0 | 3.5.0 |
| org.apache.causeway.core:causeway-applib | < 3.5.0 | 3.5.0 |
| org.apache.causeway.core:causeway-core | < 3.5.0 | 3.5.0 |
| org.apache.causeway.viewer:causeway-viewer-wicket | < 3.5.0 | 3.5.0 |
| causeway | = 4.0.0≥ 2.0.0, < 3.5.0 | 3.5.0 |
Apache Causeway faces Java deserialization vulnerabilities that allow remote code execution (RCE) through user-controllable URL parameters. These vulnerabilities affect all applications using Causeway's ViewModel functionality and can be exploited by authenticated attackers to execute arbitrary code with application privileges.
This issue affects all current versions.
Users are recommended to upgrade to version 3.5.0, which fixes the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン