n8n Improper Control of Dynamically-Managed Code Resources Vulnerability. 悪用が確認されています:CISA は 11/03/2026 にこの脆弱性を「既知の悪用された脆弱性(KEV)」カタログに追加しました。影響を受けるシステムは緊急に修正してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| n8n | = 1.121.0≥ 0.211.0, < 1.120.4 | 1.120.4 |
| n8n | ≥ 0.211.0, < 1.120.4≥ 1.121.0, < 1.121.1 | 1.120.41.121.1 |
n8n contains a critical Remote Code Execution (RCE) vulnerability in its workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime.
An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations.
This issue has been fixed in n8n v1.122.0.
Users are strongly advised to upgrade to version 1.122.0 or later, which introduces additional safeguards to restrict expression evaluation.
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
These workarounds do not fully eliminate the risk and should only be used as short-term measures.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン