| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| backstage | ≥ 1.28.0, < 1.55.0 | 1.55.0 |
| backstage/plugin-proxy-backend | ≥ 0.5.0, < 0.6.18 | 0.6.18 |
| @backstage/plugin-proxy-backend | ≥ 0.5.0, < 0.6.18 | 0.6.18 |
An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy.
Exploitation requires this specific overlapping route configuration. The resulting confidentiality and integrity impact depends on the capabilities exposed by the nested upstream.
Upgrade @backstage/plugin-proxy-backend to version 0.6.18 or later. The fixed package is available in Backstage v1.55.0.
dangerously-allow-unauthenticated.これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン