| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| @ckeditor/ckeditor5-engine | ≥ 29.0.0, < 47.7.4≥ 48.0.0, < 48.5.1 | 47.7.448.5.1 |
| ckeditor5 | ≥ 29.0.0, < 47.7.4≥ 48.0.0, < 48.5.1 | 47.7.448.5.1 |
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.
This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.
The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).
Email us at [email protected] if you have any questions or comments about this advisory.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン