要点
- CVE-2026-21893 は n8n (n8n), n8n に影響する深刻度「高」 (CVSS 7.2) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.5%(全脆弱性の 74.9% より高い)。
- 対処:1.120.3 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| n8n | ≥ 0.187.0, < 1.120.3
| 1.120.3
|
| n8n npm | ≥ 0.187.0, < 1.120.3
| 1.120.3
|
概要
Impact
A Command Injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions.
Important context
- Exploitation requires administrative access to the n8n instance.
- The affected functionality is restricted to trusted users who are already permitted to install third-party community packages.
- No unauthenticated or low-privilege exploitation is possible.
- There is no evidence of exploitation in the wild.
Because administrative users can already extend n8n with custom or community code, the vulnerability does not meaningfully expand the threat model beyond existing administrator capabilities. However, it represents a violation of secure coding practices and has therefore been addressed.
Patches
Users are advised to upgrade to n8n version 1.120.3 or later, which fully resolves the issue.
As a general security best practice, n8n instance owners should ensure that:
- Administrative access is limited to trusted users only.
- Community packages are installed only from trusted sources.
- Instances are kept up to date with the latest security releases.
NVD の説明
n8n is an open source workflow automation platform. From version 0.187.0 to before 1.120.3, a command injection vulnerability was identified in n8n’s community package installation functionality. The issue allowed authenticated users with administrative permissions to execute arbitrary system commands on the n8n host under specific conditions. This issue has been patched in version 1.120.3.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン