| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M7, < 10.1.52≥ 11.0.0-M1, < 11.0.18≥ 9.0.83, < 9.0.115 | 10.1.5211.0.189.0.115 |
| org.apache.tomcat:tomcat-coyote | ≥ 10.1.0-M7, < 10.1.52≥ 11.0.0-M1, < 11.0.18≥ 9.0.83, < 9.0.115 | 10.1.5211.0.189.0.115 |
| tomcat | = 10.1.0= 11.0.0≥ 10.1.1, < 10.1.52≥ 11.0.1, < 11.0.18≥ 9.0.83, < 9.0.115 | 10.1.5211.0.189.0.115 |
| tomcat native | ≥ 1.3.0, < 1.3.5≥ 2.0.0, < 2.0.12 | 1.3.52.0.12 |
Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat.
When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed.
This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114.
The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected.
Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue.
Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン