要点
- CVE-2026-25631 は n8n (n8n), n8n に影響する深刻度「中」 (CVSS 6.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.30%(全脆弱性の 23.3% より高い)。
- 対処:1.121.0 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| n8n | < 1.121.0
| 1.121.0
|
| n8n npm | < 1.121.0
| 1.121.0
|
概要
Impact
A vulnerability in the HTTP Request node's credential domain validation allowed an authenticated attacker to send requests with credentials to unintended domains, potentially leading to credential exfiltration.
This only might affect user who have credentials that use wildcard domain patterns (e.g., *.example.com) in the "Allowed domains" setting.
Patches
This issue is fixed in version 1.121.0 and later. All users are strongly encouraged to upgrade.
Workarounds
Until projects can upgrade:
- Replace wildcard domain patterns with explicit domain listings in HTTP Request credentials
- Review and restrict workflow creation/modification permissions to trusted users only
- Audit existing workflows using HTTP Request nodes with domain-restricted credentials
n8n has adopted CVSS 4.0 as primary score for all security advisories. CVSS 3.1 vector strings are provided for backward compatibility.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
NVD の説明
n8n is an open source workflow automation platform. Prior to 1.121.0, there is a vulnerability in the HTTP Request node's credential domain validation allowed an authenticated attacker to send requests with credentials to unintended domains, potentially leading to credential exfiltration. This only might affect user who have credentials that use wildcard domain patterns (e.g., *.example.com) in the "Allowed domains" setting. This issue is fixed in version 1.121.0 and later.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン