要点
- CVE-2026-25958 は cube.js (cube), @cubejs-backend/server-core に影響する深刻度「高」 (CVSS 7.7) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.38%(全脆弱性の 32.4% より高い)。
- 対処:1.0.14, 1.4.2, 1.5.13 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| cube.js | ≥ 0.27.19, < 1.0.14≥ 1.1.0, < 1.4.2≥ 1.5.0, < 1.5.13
| 1.0.141.4.21.5.13
|
| @cubejs-backend/server-core npm | ≥ 0.27.19, < 1.0.14≥ 1.1.0, < 1.4.2≥ 1.5.0, < 1.5.13
| 1.0.141.4.21.5.13
|
概要
Impact
It is possible to make a specially crafted request with a valid API token that leads to privilege escalation.
Affected Versions:
≥= 0.27.19
Mitigation:
Upgrade to a patched version:
- 1.5.13 and later (regular release)
- 1.4.2 (active LTS release)
- 1.0.14 (end-of-life LTS release)
References
The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.
NVD の説明
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン