| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| apache-airflow | ≥ 3.0.0, < 3.1.8 | 3.1.8 |
| airflow | ≥ 3.0.0, < 3.1.8 | 3.1.8 |
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン