| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| com.vaadin:flow-server | ≥ 23.0.0, < 23.6.7≥ 24.0.0, < 24.9.8≥ 25.0.0, < 25.0.2< 14.14.1 | 23.6.724.9.825.0.214.14.1 |
| com.vaadin:vaadin | ≥ 23.0.0, < 23.6.7≥ 24.0.0, < 24.9.8≥ 25.0.0, < 25.0.2< 14.14.1 | 23.6.724.9.825.0.214.14.1 |
| vaadin | ≥ 10.0.0, < 14.14.1≥ 15.0.0, < 23.6.7≥ 24.0.0, < 24.9.8≥ 25.0.0, < 25.0.2 | 14.14.123.6.724.9.825.0.2 |
An authentication bypass vulnerability exists in Vaadin 14.0.0 through 14.14.0, 23.0.0 through 23.6.6, 24.0.0 through 24.9.7 and 25.0.0 through 25.0.1, applications using Spring Security due to inconsistent path pattern matching of reserved framework paths.
Accessing the /VAADIN endpoint without a trailing slash bypasses security filters, and allowing unauthenticated users to trigger framework initialization and create sessions without proper authorization.
Users of affected versions using Spring Security should upgrade as follows: 14.0.0-14.14.0 upgrade to 14.14.1, 23.0.0-23.6.6 to 23.6.7, 24.0.0 - 24.9.7 to 24.9.8, and 25.0.0-25.0.1 upgrade to 25.0.2 or newer.
Please note that Vaadin versions 10-13 and 15-22 are no longer supported and users should update either to the latest 14, 23, 24, 25 version.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン