要点
- CVE-2026-27888 は pypdf, pypdf (pypdf project) に影響する深刻度「高」 (CVSS 7.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.40%(全脆弱性の 34.1% より高い)。
- 対処:6.7.3 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| pypdf PyPI | < 6.7.3
| 6.7.3
|
| pypdf | < 6.7.3
| 6.7.3
|
概要
Impact
An attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing the xfa property of a reader or writer and the corresponding stream being compressed using /FlateDecode.
Patches
This has been fixed in pypdf==6.7.3.
Workarounds
If projects cannot upgrade yet, consider applying the changes from PR #3658.
NVD の説明
pypdf is a free and open-source pure-python PDF library. Prior to 6.7.3, an attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing the `xfa` property of a reader or writer and the corresponding stream being compressed using `/FlateDecode`. This has been fixed in pypdf 6.7.3. As a workaround, apply the patch manually.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン