| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/hashicorp/consul | ≥ 1.19.0, < 1.21.11≥ 1.22.0-rc1, < 1.22.5< 1.18.21< 1.22.5 | 1.21.111.22.51.18.21 |
HashiCorp Consul and Consul Enterprise 1.18.20 up to 1.21.10 and 1.22.4 are vulnerable to arbitrary file read when configured with Kubernetes authentication. This vulnerability, CVE-2026-2808, is fixed in Consul 1.18.21, 1.21.11 and 1.22.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free