要点
- CVE-2026-30949 は parse-server (parseplatform), parse-server に影響する深刻度「高」 (CVSS 8.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.45%(全脆弱性の 39.3% より高い)。
- 対処:9.5.2, 8.6.18, 9.5.2-alpha.5 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| parse-server | = 9.5.2≥ 9.0.0, < 9.5.2< 8.6.18
| 9.5.28.6.18
|
| parse-server npm | ≥ 9.0.0, < 9.5.2-alpha.5< 8.6.18
| 9.5.2-alpha.58.6.18
|
概要
Impact
The Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms.
All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected.
Patches
The fix replaces the userinfo HTTP call with local JWT verification and enforces azp claim validation against the configured client-id.
Workarounds
None.
References
NVD の説明
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.5 and 8.6.18, the Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms. All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected. This vulnerability is fixed in 9.5.2-alpha.5 and 8.6.18.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン