要点
- CVE-2026-32061 は openclaw (openclaw), openclaw に影響する深刻度「中」 (CVSS 4.4) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.15%(全脆弱性の 4.3% より高い)。
- 対処:2026.2.17 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| openclaw | < 2026.2.17
| 2026.2.17
|
| openclaw npm | < 2026.2.17
| 2026.2.17
|
概要
Vulnerability
Path traversal in config $include resolution allowed arbitrary local file reads outside the config directory boundary (CWE-22).
Attack Vectors
- If an attacker can modify OpenClaw config, they can set
$include to absolute paths (for example /etc/passwd) and read files accessible to the OpenClaw process.
- If an attacker can modify OpenClaw config, they can use traversal paths (for example
../../...) to escape the config directory.
- If an attacker can create symlinks inside the config directory, they can point includes to external files unless real-path checks are enforced.
- Impact scope is bounded by the file permissions of the OpenClaw runtime user; this is not an unauthenticated remote-only vector by itself.
Impact
A successful exploit can expose local secrets and credentials readable by the OpenClaw process user, including API keys and private config material.
Affected Packages / Versions
- Package:
openclaw (npm)
- Vulnerable versions:
<=2026.2.15
- Patched versions:
>=2026.2.17
Fix Commit(s)
d1c00dbb7c64a39e205464dae7f2a068420e91c1
Release Process Note
Patched version is pre-set to 2026.2.17. Once npm release 2026.2.17 is available, this advisory is ready to publish.
OpenClaw thanks @aether-ai-agent for reporting.
NVD の説明
OpenClaw versions prior to 2026.2.17 contain a path traversal vulnerability in the $include directive resolution that allows reading arbitrary local files outside the config directory boundary. Attackers with config modification capabilities can exploit this by specifying absolute paths, traversal sequences, or symlinks to access sensitive files readable by the OpenClaw process user, including API keys and credentials.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン