| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.spark:spark-core_2.12 | ≥ 3.0.0, < 3.5.8 | 3.5.8 |
| org.apache.spark:spark-core_2.13 | ≥ 3.0.0, < 3.5.8 | 3.5.8 |
| pyspark | ≥ 3.0.0, < 3.5.8 | 3.5.8 |
| spark | ≥ 3.0.0, < 3.5.8 | 3.5.8 |
There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later.
This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page.
Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン