| Package | Affected versions | Patched versions |
|---|---|---|
| enterprise server | ≥ 3.15.0, < 3.15.19≥ 3.16.0, < 3.16.15≥ 3.17.0, < 3.17.12≥ 3.18.0, < 3.18.6≥ 3.19.0, < 3.19.3< 3.14.24 | 3.15.193.16.153.17.123.18.63.19.33.14.24 |
An improper authorization vulnerability was identified in GitHub Enterprise Server that allowed a user with read access to a repository and write access to a project to modify issue and pull request metadata through the project. When adding an item to a project that already existed, column value updates were applied without verifying the actor's repository write permissions. This vulnerability was reported via the GitHub Bug Bounty program and has been fixed in GitHub Enterprise Server versions 3.14.24, 3.15.19, 3.16.15, 3.17.12, 3.18.6 and 3.19.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free