要点
- CVE-2026-34052 は jupyterhub-ltiauthenticator, lti jupyterhub authenticator (jupyter) に影響する深刻度「中」 (CVSS 5.9) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.34%(全脆弱性の 27.7% より高い)。
- 対処:1.6.3 以降に更新してください。
概要
Summary
The LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service.
Patches
- upgrade jupyterhub-litauthenticator to 1.6.3
NVD の説明
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
jupyterhub-ltiauthenticator のその他の脆弱性
すべて見る →これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン