要点
- CVE-2026-34236 は auth0/auth0-php, auth0-php (auth0) に影響する深刻度「緊急」 (CVSS 9.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.22%(全脆弱性の 13.2% より高い)。
- 対処:8.19.0 以降に更新してください。
概要
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
Consumers are affected if their application meets the following preconditions:
- Their application is using the Auth0-PHP SDK, versions between 8.0.0 and 8.18.0
- Their application is using the Auth0-PHP SDK, or the following SDKs that rely on the Auth0-PHP SDK:
- Auth0/symfony,
- Auth0/laravel0-auth0, or
- Auth0/wordpress
Resolution
Upgrade Auth0/Auth0-PHP to version 8.19.0 or greater.
NVD の説明
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン