| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.flink:flink-table-api-java | ≥ 1.15.0, < 1.20.4≥ 2.0.0, < 2.0.2≥ 2.1.0, < 2.1.2≥ 2.2.0, < 2.2.1 | 1.20.42.0.22.1.22.2.1 |
| org.apache.flink:flink-table-planner_2.12 | ≥ 1.15.0, < 1.20.4≥ 2.0.0, < 2.0.2≥ 2.1.0, < 2.1.2≥ 2.2.0, < 2.2.1 | 1.20.42.0.22.1.22.2.1 |
| org.apache.flink:flink-table-runtime | ≥ 1.15.0, < 1.20.4≥ 2.0.0, < 2.0.2≥ 2.1.0, < 2.1.2≥ 2.2.0, < 2.2.1 | 1.20.42.0.22.1.22.2.1 |
| flink | = 2.2.0≥ 1.15.0, < 1.20.4≥ 2.0.0, < 2.0.2≥ 2.1.0, < 2.1.2 | 1.20.42.0.22.1.2 |
Code injection in SQL code generation in Apache Flink 1.15.0 through 1.20.x and 2.0.0 through 2.x allows authenticated users with query submission privileges to execute arbitrary code on TaskManagers via maliciously crafted SQL queries. The vulnerability affects JSON functions (1.15.0+) and LIKE expressions with ESCAPE clauses (1.17.0+). User-controlled strings are interpolated into generated Java code without proper escaping, allowing attackers to break out of string literals and inject arbitrary expressions.
Users are recommended to upgrade to either version 1.20.4, 2.0.2, 2.1.2 or 2.2.1, which fixes this issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン