要点
- CVE-2026-40293 は github.com/openfga/openfga, openfga (openfga) に影響する深刻度「中」 (CVSS 6.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.29%(全脆弱性の 21.2% より高い)。
- 対処:1.14.0 以降に更新してください。
概要
Description
When OpenFGA is configured to use preshared-key authentication with the built-in playground enabled, the local server includes the preshared API key in the HTML response of the /playground endpoint. The /playground endpoint is enabled by default and does not require authentication. It is intended for local development and debugging and is not designed to be exposed to production environments.
Am I Affected?
You are affected if you meet each of the following preconditions:
- You are running OpenFGA with --authn-method preshared, and
- The playground is enabled, and
- The playground endpoint is accessible beyond localhost or trusted networks.
Fix
Upgrade to OpenFGA v1.14.0, or disable the playground by running ./openfga run --playground-enabled=false.
NVD の説明
OpenFGA is an authorization/permission engine built for developers. In versions 0.1.4 through 1.13.1, when OpenFGA is configured to use preshared-key authentication with the built-in playground enabled, the local server includes the preshared API key in the HTML response of the /playground endpoint. The /playground endpoint is enabled by default and does not require authentication. It is intended for local development and debugging and is not designed to be exposed to production environments. Only those who run OpenFGA with `--authn-method` preshared, with the playground enabled, and with the playground endpoint accessible beyond localhost or trusted networks are vulnerable. To remediate the issue, users should upgrade to OpenFGA v1.14.0, or disable the playground by running `./openfga run --playground-enabled=false.`
github.com/openfga/openfga のその他の脆弱性
すべて見る →これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン