| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.springframework.boot:spring-boot | ≥ 4.0.0, < 4.0.6 | 4.0.6 |
| spring boot | ≥ 4.0.0, < 4.0.6 | 4.0.6 |
In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable.
Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン